I had a massive update from PHP5.6 to PHP7.1 and and server components. Plus Joomla to latest version. Please if something does not work report on forum.

Guest
15 May 2019 18:05

When attempting to reply to comments in any topic or category, the modal 'add comments' pop up displays but it is covered with a gray block. When I click, it closes the modal comment box.

I have tried with different browsers, different users and permission levels and looked through the section, type, category and field attributes and template defaults and don't find anything about comment reply permissions or display.

Which setting do I need to allow reply to comments?

Thank you

Last Modified: 17 May 2019


Giorgi625 VIP
Total posts: 529
15 May 2019 18:25

What template do you use?

Cobalt has problems with BS3 and BS4 templates in features which is loaded via Modals.

Can you post screenshots to show us how it looks and if possible url of page with problem.


Guest
15 May 2019 18:56

Thank you

I am using SevenThemes HLI template

snap1 snap2

how can I securely send url?


Guest
15 May 2019 18:58

Just a thought... perhaps I should change the editor?


Giorgi625 VIP
Total posts: 529
15 May 2019 21:47

I am using same editor but don't have modal window. when I click on quote it simply adds quoted comment to editor area where I can type my answer and post Click here to link...

check if same problem appears on protostar or other templates.


Guest
16 May 2019 03:37

Thank you.

I checked with protostar and the same happened.

I will check with the template developer to see what they say


Guest
16 May 2019 04:25

Upon inspecting element I found this code but not familiar with the backend so am unaware of which file:

<a class="btn btn-mini btn-primary" href="#commentmodal" data-toggle="modal" role="button" onclick="Cobalt.editComment(0,23,12)>

Values for data-toggle include collapse dropdown modal tab pill button(s)

Could this be something to change? Thank you


Giorgi625 VIP
Total posts: 529
16 May 2019 11:10

This code is for edit already submited comment. So I have question do you get this modal when you try to edit comment or submit new one?

I checked now edit of comment on protostar on my demo site and it works fine. So if you have problems on protostar too then there is some conflict I guess which is not related to your template, but maybe to plugin or some other extension, because your tempalte works on Bootstrap 2, which is fully compatible with Cobalt CCK.

What does your browser console show? are there any errors?


Guest
16 May 2019 14:10

Comments are working fine. this happens when I am trying to reply to an already submitted comment, e.g., clicking on the 'Reply' button

There are no error messages, but I am assuming the gray box is some kind of error condition.

btw, it works fine when I am editing a comment


Guest
16 May 2019 16:44

I found this, which is exactly how this is behaving for me.

I hope it is helpful. Thank you

https://stackoverflow.com/questions/41292673/bootstrap-modal-opens-but-stays-in-gray-background-and-cannot-close-or-interact


Giorgi625 VIP
Total posts: 529
16 May 2019 16:52

It is strange , because it should not even use modal for adding/replying comment.

It should simply paste quote to editor which is below comments.

Can you give a link to page with problem?


Guest
16 May 2019 18:12

So I discovered the comment template was set to 'default' rather than 'forum'. I have changed and the button now says 'quote' instead of 'reply' and now the quote function works fine. however, now I am not able to edit comments. It pops up the modal 'edit comment' box then the gray masking. I am able to edit the topic fine as it is not modal. you can test with login test5, pwd test5. The login button is the right arrow in the upper right of the header http://www.my-life-capsule.com/gigit_work/index.php/members-only/community-forum-pack073a51/user-item/368-tschiel/11-subcategory-2-1/18-another-new-topic-for-cat-2-1


Giorgi625 VIP
Total posts: 529
16 May 2019 18:51

you can add

div.modal-backdrop {
    z-index: 0;
    background-color: #fff;
}

this to your custom.css file or if tempalte has option to add custom styles then add that code there.

if it will not work you can use this.

div.modal-backdrop {
    z-index: 0 !improtant;
    background-color: #fff !improtant;
}

If you don't use modals anywhere else, this will help. if you use modals on other places, check what will happen to them after this edit.


Guest
17 May 2019 16:14

I tried both of these in the custom.css file, relaunched and neither worked.

I am going to try to just disable comment edit perms as a workaround. If that doesn't work, I will try something else.

Thank you for your help. Have a great weekend


Giorgi625 VIP
Total posts: 529
17 May 2019 20:00

Guest I tried both of these in the custom.css file, relaunched and neither worked.

I am going to try to just disable comment edit perms as a workaround. If that doesn't work, I will try something else.

Thank you for your help. Have a great weekend

Have you cleaned cache? It should work. If not then I don't know whats wrong.

Thanks, have a great weekend too.

Replay Topic
Uploading
Click here to upload and insert file from you hard drive: (png, gif, jpg, jpeg, zip, txt, rar)
Powered by Cobalt