pepperstreet VIP
Total posts: 3,834
08 May 2013 19:41

Found some issues with the following module layouts:

Default / General

  • Show Article items YES, max 5 items. But no articles are listed!?

parameter in module backend:


DropDownMenu

  • There is a bare, linked SectionName. But it does link to the frontpage. Shouldn´t it link to the section list? Or even better: Open the DropDown itself? The bootstrap SPLIT variant in a navbar is not user-friendly. Hard to know, that there are TWO different links.

  • very tiny arrow on the right. Only clicking that small arrow opens a submenu in Bootstrap style.

Suggestions:
Since BS menus require an item to open the dropmenu on click, I would suggest to:

A.) open menu on first SectionName, add SectionLink as extra item, maybe followed by separator

B.) use BS Buttongroup with Split. Left side is Link to Section, right side opens Dropdown

C.) Submenu drop direction. Could you add the different menu directions that are available in bootstrap? Otherwise submenus might get out of sight. There are left, right and up, AFAIK.

D.) Module Parameter: Show Section YES/NO. Not sure how to deal with that...? BS menu needs always a trigger link. So, YES is mandatory.


MooTree

  • Upper Section Name has no link to section list?!
  • Suggestion: default icons are way too small, and not suitable. Should be closed/open folders. Or simpler symbols. BS Icons?
  • Suggestion: jQuery replacement! Maybe keep MooTree as Alt layout? (i.e. see FuelUX Tree, there is also a BootstrapTree project, also found 2 Trees on Bootsnipp, or other jQuery plugins? Joomla JUI comes with jQuery TreeSelectMenu for MenuAssignment)

EDITs:

  • AJAX error was solved, removed my screenshots :)
  • added more screenshots for other layouts!
  • new text formatting, due to new Cobalt forum

Last Modified: 22 May 2017



pepperstreet VIP
Total posts: 3,834
24 Sep 2014 00:39

AJAX Select - some issues

  • Shouldn't it work with the parameter "Empty Categories -> NO" ? It does hide the empty categories, but then it should navigate to the previously selected option. Currently it updates the next select with no options (except for text CSELECT).

In other words, I have to set "Empty Categories -> YES" to make it work. But also this feels wrong, because I have to select an Option with count (0).

empty_categories


  • After selecting an option, the next selectbox text changes to a language constant CSELECT

after_first_selection_cselect_constant_appears


  • After redirect to selected category and respective list view... the module reverts back to initial status. It does not inherit the selection.

after_redirect_navigation


  • Labels: I noticed that the select behavior changes with "Labels". If there is a label, it shows the selectbox. If I have 3 labels for 3 levels it shows 3 selectboxes. I expected them to show one after the other (step by step, interactive) ?

No labels are not possible? No labels hide ALL selectboxes.

What is the initial idea for the labels? Shouldn't it replace the first option inside selectbox ( -choose- ) ?


  • Missing single record item display. Could be displayed under category name (indented with spaces or dash)

Konstantin
Total posts: 1,113
25 Sep 2014 07:44

Make some fixes: translates and populate.


pepperstreet VIP
Total posts: 3,834
25 Sep 2014 19:58

pepperstreet Labels: I noticed that the select behavior changes with "Labels". If there is a label, it shows the selectbox. If I have 3 labels for 3 levels it shows 3 selectboxes. I expected them to show one after the other (step by step, interactive) ?

Just to clarify my "complaint" about current behavior, UI and UX. I think it should reveal the next selectbox one after the other.

Examples - Similar field behavior:

pepperstreet VIP
Total posts: 3,834
22 May 2017 00:33

@Sergey
A gentle reminder for a functionality check and parameters.

  • Records display (not available in default, tree does not work either)
  • MooTools powered tree removal and replacement?
  • DropDown layout does not work? Layout file seem to have 2 different(?) display styles and markup in the code (maybe re-invented from an older file?)
  • Other parameters not working correctly e.g. Section Name, Custom CSS Classes, Module Suffix

Thanks for listening.


Related topic and issue with Record-Items display

Powered by Cobalt