Dan2010
Total posts: 9
07 Nov 2014 16:26

Hello.

I just purchased your plugin and set up everything by following the instruction on the website. Whenever I click to make payment, the site gives a white screen. I turned on error reporting for my website and I got the information below:

Warning: array_shift() expects parameter 1 to be array, null given in /home/xxx/public_html/plugins/hikashoppayment/pay2co/pay2co.php on line 87 `` Fatal error: Cannot access empty property in /home/xxx/public_html/libraries/framework/Joomla/Registry/Registry.php on line 506

Can you please explain how this can be fixed?

I also noticed that you cannot set the plugin to Demo. Each time I select and save, it returns back to OFF. So if I leave it off and used the Parameter setting in 2CO Site Management, orders would not be treated as a Demo so testing the plugin may become an issue.

My shop is set and the only thing delaying my take off now is the plugin.

Thank you.

Niyi

Last Modified: 08 Dec 2014


Dan2010
Total posts: 9
08 Nov 2014 09:18

Hi

While waiting for your response. I thought I should provide more information. I am using Joomla 3.3.1 and Hikashop 2.3.4 If there is any other information required, please let me know.

Daniel


Dan2010
Total posts: 9
10 Nov 2014 15:27

Hello

Is anyone there? I have not recieved a simple response that my issue is being looked into. How long do I wait for a response?

Daniel


Dan2010
Total posts: 9
10 Nov 2014 22:24

Hello guys,

No one has responded to my request and I really dont know what to expect or how long to wait. I am under pressure to complete the website and after paying over 40USD for a plugin which is not working, waited through the weekend hoping for a response once the weekend is over and yet still not getting any feedback after three days is discouraging. If I do not get a response by the end of Tuesday 11th November 2014, I'm sorry I would be forced to look elsewhere and request a refund through Paypal. I hope you this is a decision I would not have to take, but I think its only fair I let you know this.


Sergey
Total posts: 13,718
11 Nov 2014 03:50

I very apologize. Just accidentely I found this topic. Somehow I missed it and did not follow it. This will not happen again. I am so embarrassed.

I can refund you if you still want a refund, but at the same time I uploaded fixed version. So what ever you deside I will do.


Dan2010
Total posts: 9
11 Nov 2014 07:32

Hello

Thank you for your response. I very much want to finish the website so if your plugin works well, then I am happy. However, after installing the new version, I still get a blank screen with this message: Fatal error: Cannot access empty property in mysite\libraries\framework\Joomla\Registry\Registry.php on line 506

How can I resolve this?

Dan


Sergey
Total posts: 13,718
11 Nov 2014 14:49

Please give me login access in private comment I'll check it on-site.


Dan2010
Total posts: 9
12 Nov 2014 08:10

Hi

I am sorry I have to request for a refund of the payment we made. We have lost time on this and we have to switch to our backup plan which means abandoning Hikashop altogether. 2CO is the only payment provider that can be used in my client's country and since Hikashop has no other recommended option than yours, we have decided to avoid it for now.

Thanks you.


Sergey
Total posts: 13,718
12 Nov 2014 09:57

So should I proseed with fixing?


Dan2010
Total posts: 9
12 Nov 2014 10:38

Hi

Sorry we have concluded that we should switch to our former cart instead of Hikashop because of the 2CO plugin issue. Maybe in the future we may reconsider but for now, we do not want to risk it since we have no time, the plugin has repeated issues and the support takes time.

Thank you.


Sergey
Total posts: 13,718
14 Nov 2014 02:41

Ok.


sograph
Total posts: 1
07 Dec 2014 03:51

I am having the same problem, was there ever a quick fix?

Fatal error: Cannot access empty property in /home/XXX/public_html/libraries/framework/Joomla/Registry/Registry.php on line 506

Thanks, Dan


Sergey
Total posts: 13,718
08 Dec 2014 08:54

The quickest is to create new topic and there give me admin access to your site. I'll login and test.

Also describe how to reproduce this error.

Replay Topic
Uploading
Click here to upload and insert file from you hard drive: (png, gif, jpg, jpeg, zip, txt, rar)
Powered by Cobalt