I had a massive update from PHP5.6 to PHP7.1 and and server components. Plus Joomla to latest version. Please if something does not work report on forum.

Guest
02 May 2013 18:20

Hello,

We believe we have everything set up correctly but are not seeing the payments on the joomla Emerald 8 backend from either Paypal or 2CO. Paypal has an IPN set up, but still no payments showing.

The payments are being processed in Paypal, but not showing the Emerald 8.

Please can you advise on the fix needed.

Darren

Last Modified: 09 Jul 2015


Sergey
Total posts: 13,645
06 May 2013 00:41

Please check that all links in menu to Emerald are public. They may be in for "registered" menu but should be public.

In paypal. check IPN history and post here IPN URLs I'll check.


Guest
06 May 2013 14:38

Sergey,

I reviewed the menu items and they are set to 'public'. I went into Paypal and verified that the url is:

http://www.professionalsoccercoaching.com/index.php

The IPN hsitory shows one current payment going through. However, I just did a test on the 2CO with my credit card and it also does not show in the backend either. So it appear not just related to Paypal.

Let me know,

Thx

Darren


Guest
06 May 2013 18:05

Sergey, Would you be able to login and review what is wrong here? I can send you detials to look in the backend?

Darren


Sergey
Total posts: 13,645
07 May 2013 10:05

yes please send details in private comment. Also look inside IPN history and there should be URL it trys to send IPN to. I need this URL.


Guest
07 May 2013 11:09

Hidden text


Sergey
Total posts: 13,645
08 May 2013 01:13

GDid you ever try to open this URL? It say that URL is not found. Why you have com_jcs? Those looks like old urls of old Mighty Membership extension.

I have developed small adopter. please download attached file. Create empty com_jcs folder in components/ and put jcs.php file in there. It should accept old IPN urls.


Guest
09 May 2013 19:55

I uploaded the above.

I went in and tested. I got a new payment to show up, I will wait and see on a recurring one which hopefully will come by in the next few days, so I'll let you know.

I tested on 2CO with a new payment and could not get a 2CO payment to process at this point? Can you help to get payments to be processed in the Emerald 8 backend also?

Darren

The payment shown below did not appear in the emerald 8 backend:

Hidden text


Sergey
Total posts: 13,645
10 May 2013 07:59

2CO also have INS history. Please check what it tells there.

This is not recurring payment right? This is regular already done in Emerald?


Guest
10 May 2013 11:32

A recurring payment I received today did not go through (via Paypal). Attached is an image of the payment.


Guest
10 May 2013 14:34

I checked the 2CO INS history and it appears to be off. What is the url for my site I should enter for this to work? Should I enter it in the global url field? It didn't used to process on Mighty Membership as a recurring payment (although, I would like it to if that is now possible). Please let me know how to set that up. I see the recurring complete field in 2CO also.

Darren


Guest
10 May 2013 15:04

I found the notes on the 2CO payments and entered http://professionalsoccercoaching.com/index.php?option=com_emerald& ;task=plans.create&processor=pay2co&pay=success&tmpl=component, so I'll test that works.

Please let me know on the recurring issues still.


Sergey
Total posts: 13,645
12 May 2013 04:00

Please let me know on the recurring issues still.

For 2co or paypal?

How is paypal? Working?


Guest
13 May 2013 11:37

Hi Sergey,

1) I cannot get a payment to process successfully in Emerald 8 for 2CO. I have attached a screen shot of the returned message. The payment is actually taking place, (as I get the confirmation email to my email account from 2CO). But it is not showing in Emerald 8.

2) Paypal is only processing single new payments in Emerald 8. The recurring payments that have been billing in Paypal are not showing still.

I can send you my Paypal and 2CO account details if you need to go in a test and configure these yourself?

Darren


Guest
13 May 2013 11:55

Here is the message that was returned from 2CO.


Guest
15 May 2013 11:10

Hi Sergey,

Is there anything else you need to help resolve these issues? I really need to get this up and running as I have payments coming in and not entering the joomla backend. Let me know and I'll get you what you need.

Thx

Darren


Guest
16 May 2013 14:19

Hello,

I have not heard back from anyone for 5 days. Im still waiting for assistance and this is an urgent issue with live customers. Please can someone help me to resolve the issues with the plugins.

Thx

Darren


Sergey
Total posts: 13,645
20 May 2013 00:19

I apologize for delay in response. I am working on it right now...


Sergey
Total posts: 13,645
20 May 2013 00:23

But you plans do not have 2CO payment configured. there is no Vendor ID or other things.


Guest
20 May 2013 19:00

I just went into the payment plan and also to the payment plan through the plan itself and this information is there. Are you looking somewhere else? See attached for the screen shot with the configuration I am seeing.


Guest
20 May 2013 19:02

Please review numberin.jpg for the set-up. 2codata.jpg uploaded incorrectly.

Replay Topic
Uploading
Click here to upload and insert file from you hard drive: (png, gif, jpg, jpeg, zip, txt, rar)
Powered by Cobalt